Difference between revisions of "Naming Conventions"
SaschaZelzer (talk | contribs) |
(Add link to style guide in the nigthly documentation) |
||
(5 intermediate revisions by 2 users not shown) | |||
Line 1: | Line 1: | ||
__NOTOC__ | __NOTOC__ | ||
− | + | This page is about naming conventions of application and module source directories and build artifacts. For more naming conventions and MITK style guide, please have a look [http://docs.mitk.org/nightly/StyleGuideAndNotesPage.html here]. | |
− | |||
== Situation until 2013.12 == | == Situation until 2013.12 == | ||
Line 8: | Line 7: | ||
Until MITK 2013.12 there was no official naming scheme, resulting in a mix of different styles. | Until MITK 2013.12 there was no official naming scheme, resulting in a mix of different styles. | ||
− | |||
+ | === Source tree === | ||
− | < | + | <syntaxhighlight lang="cpp"> |
Applications/ | Applications/ | ||
CoreApp | CoreApp | ||
Line 22: | Line 21: | ||
QmitkExt | QmitkExt | ||
QmlMitk | QmlMitk | ||
− | </ | + | </syntaxhighlight> |
− | + | === Build artifacts === | |
Current build artifacts in MITK-build/bin: | Current build artifacts in MITK-build/bin: | ||
− | + | <syntaxhighlight lang="cpp"> | |
− | < | ||
ImageExtractionTestDriver | ImageExtractionTestDriver | ||
MitkTestDriver | MitkTestDriver | ||
Line 46: | Line 44: | ||
libQmlMitk.so | libQmlMitk.so | ||
... | ... | ||
− | </ | + | </syntaxhighlight> |
Line 55: | Line 53: | ||
# Qt dependent module directories and module names are prefixed with "Qt" or "Qml" (some modules will need to be renamed). They will then also additionally get the "Mitk" prefix. | # Qt dependent module directories and module names are prefixed with "Qt" or "Qml" (some modules will need to be renamed). They will then also additionally get the "Mitk" prefix. | ||
− | |||
+ | === New source tree layout === | ||
− | < | + | <syntaxhighlight lang="cpp"> |
Applications/ | Applications/ | ||
CoreApp | CoreApp | ||
− | Workbench | + | Workbench ← previously "mitkWorkbench" |
Modules/ | Modules/ | ||
CameraCalibration | CameraCalibration | ||
− | AlgorithmsExt | + | AlgorithmsExt ← previously "MitkAlgorithmsExt" |
− | QtWidgets | + | QtWidgets ← previously "Qmitk" |
− | QtWidgetsExt | + | QtWidgetsExt ← previously "QmitkExt" |
− | QmlWidgets | + | QmlWidgets ← previously "QmlMitk" |
− | </ | + | </syntaxhighlight> |
− | + | === New build artifact naming === | |
New build artifacts in MITK-build/bin: | New build artifacts in MITK-build/bin: | ||
− | + | <syntaxhighlight lang="cpp"> | |
− | + | MitkImageExtractionTestDriver ← previously "ImageExtractionTestDriver" | |
− | MitkImageExtractionTestDriver | ||
MitkTestDriver | MitkTestDriver | ||
− | MitkCameraCalibrationTestDriver | + | MitkCameraCalibrationTestDriver ← previously "mitkCameraCalibrationTestDriver" |
− | MitkWorkbench | + | MitkWorkbench ← previously "mitkWorkbench" |
− | MitkCoreApp | + | MitkCoreApp ← previously "CoreApp" |
− | MitkIGTTutorialStep1 | + | MitkIGTTutorialStep1 ← previously "mitkIGTTutorialStep1" |
− | MitkStep1 | + | MitkStep1 ← previously "Step1" |
− | libMitkConnectomics.so | + | libMitkConnectomics.so ← previously "libConnectomics.so" |
libMitkAlgorithmsExt.so | libMitkAlgorithmsExt.so | ||
− | libMitkCameraCalibration.so | + | libMitkCameraCalibration.so ← previously "libmitkCameraCalibration.so" |
− | libMitkQtWidgets.so | + | libMitkQtWidgets.so ← previously "libQmitk.so" |
− | libMitkQmlWidgets.so | + | libMitkQmlWidgets.so ← previously "libQmlMitk.so" |
− | </ | + | </syntaxhighlight> |
+ | |||
+ | |||
+ | [[Category:Development]] |
Latest revision as of 15:14, 9 June 2016
This page is about naming conventions of application and module source directories and build artifacts. For more naming conventions and MITK style guide, please have a look here.
Situation until 2013.12
Until MITK 2013.12 there was no official naming scheme, resulting in a mix of different styles.
Source tree
<syntaxhighlight lang="cpp"> Applications/
CoreApp mitkWorkbench
Modules/
CameraCalibration MitkAlgorithmsExt Qmitk QmitkExt QmlMitk
</syntaxhighlight>
Build artifacts
Current build artifacts in MITK-build/bin:
<syntaxhighlight lang="cpp"> ImageExtractionTestDriver MitkTestDriver mitkCameraCalibrationTestDriver
mitkWorkbench CoreApp mitkIGTTutorialStep1 Step1
libConnectomics.so libMitkAlgorithmsExt.so libmitkCameraCalibration.so libQmitk.so libQmlMitk.so ... </syntaxhighlight>
Change proposal
- No "mitk" string in source tree directories. There is no need to state that a module or appication belongs to "mitk", since it is already contained in the MITK source tree.
- All build artifacts and module names are prefixed with "Mitk" (the prefix will be configurable for external projects). Module names are visible from external projects and should carry a prefix identifying the project where the module is hosted. The same is true for build artifact names like shared library names.
- Qt dependent module directories and module names are prefixed with "Qt" or "Qml" (some modules will need to be renamed). They will then also additionally get the "Mitk" prefix.
New source tree layout
<syntaxhighlight lang="cpp"> Applications/
CoreApp Workbench ← previously "mitkWorkbench"
Modules/
CameraCalibration AlgorithmsExt ← previously "MitkAlgorithmsExt" QtWidgets ← previously "Qmitk" QtWidgetsExt ← previously "QmitkExt" QmlWidgets ← previously "QmlMitk"
</syntaxhighlight>
New build artifact naming
New build artifacts in MITK-build/bin:
<syntaxhighlight lang="cpp"> MitkImageExtractionTestDriver ← previously "ImageExtractionTestDriver" MitkTestDriver MitkCameraCalibrationTestDriver ← previously "mitkCameraCalibrationTestDriver"
MitkWorkbench ← previously "mitkWorkbench" MitkCoreApp ← previously "CoreApp" MitkIGTTutorialStep1 ← previously "mitkIGTTutorialStep1" MitkStep1 ← previously "Step1"
libMitkConnectomics.so ← previously "libConnectomics.so" libMitkAlgorithmsExt.so libMitkCameraCalibration.so ← previously "libmitkCameraCalibration.so" libMitkQtWidgets.so ← previously "libQmitk.so" libMitkQmlWidgets.so ← previously "libQmlMitk.so" </syntaxhighlight>